Website Downtime
Incident Report for Infura
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 18:22 UTC
Investigating
We're experiencing internal networking failures and are currently looking into the issue.
Posted Sep 18, 2020 - 18:19 UTC
This incident affected: Infura Website (Website pages).