Degraded performance for Base Mainnet JSON-RPC API

Incident Report for Infura

Update

We're currently experiencing increased latency for eth_getLogs requests on Base Mainnet, particularly when querying historical logs. Other RPC methods are unaffected. We recommend querying near-head data or using smaller block ranges (under 10,000 blocks) whenever possible for more reliable results. Our team is actively monitoring the situation and working to improve performance.
Posted May 25, 2025 - 09:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 25, 2025 - 09:08 UTC

Investigating

We have observed degraded performance on some Base Mainnet JSON-RPC API endpoints, manifesting as elevated response times for a portion of users accessing the listed components. We are currently investigating to pinpoint a root cause and remediate.
Posted May 25, 2025 - 09:07 UTC
This incident affects: Infura Base APIs (Base Mainnet).