Mainnet Websocket Filter Instability
Incident Report for Infura
Resolved
We have confirmed that the remaining filters are stable, and will reassess how best to again offer eth_newPendingTransactionFilter functionality in a future update. In the meantime, users of the eth_newPendingTransactionFilter RPC should contact Infura support for alternative means of accessing pending transaction data.
Posted Feb 13, 2020 - 00:39 UTC
Update
The root cause of this instability has been identified as instability in the eth_newPendingTransactionFilter RPC. To mitigate this issue we've disabled this RPC for the time being. Users of this RPC should contact Infura support for alternative means of accessing pending transaction data.
Posted Feb 12, 2020 - 23:58 UTC
Monitoring
We have failed over mainnet filters to alternative infrastructure and are continuing to monitor the stability of the filtering system before considering the issue fully resolved.
Posted Feb 12, 2020 - 22:16 UTC
Update
We are continuing to investigate instability in mainnet websocket filters, the stability of filter RPCs on mainnet is still impacted. We are working on bringing up additional alternative capacity for filter load while continuing to investigate the root cause.
Posted Feb 12, 2020 - 21:20 UTC
Investigating
We are currently investigating increased instability in websocket filters on mainnet. This instability may affect the creation of new filters and delivery of existing filter updates, which may lead to websocket disconnection. Note that connections only using subscriptions via the eth_subscribe RPC should not be affected, but connections that intermingle subscriptions and filters may be impacting.
Posted Feb 12, 2020 - 20:28 UTC
This incident affected: Infura Ethereum API (Mainnet WebSocket JSON-RPC API).