Robinhood Testnet JSON-RPC Degraded

Incident Report for Infura

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 07:46 UTC

Investigating

Robinhood Testnet JSON-RPC is experiencing degraded performance due to upstream provider service issues, resulting in stalled chain indexing and stale data. We will continue to provide updates as more information becomes available.
Posted Jul 30, 2026 - 07:30 UTC