Consensus Issues on Ropsten
Incident Report for Infura
Resolved
We've completed the transition of all facets of our Ropsten infrastructure to the new chain and will continue to monitor the network for stability. Any user that sent transactions between blocks 10679538 and 10688318 on the old chain are encouraged to double check that they are still mined on the new chain.
Posted Jul 23, 2021 - 01:16 UTC
Update
We are continuing to update our Ropsten infrastructure to the the new consensus chain. As we migrate portions of our infrastructure to the new chain users can expect to see inconsistent results, especially between logs/events and block contents. As such users are further encouraged to avoid using Ropsten until this process is complete.
Posted Jul 23, 2021 - 00:16 UTC
Update
We are beginning the process of upgrading our Ropsten nodes to resolve the consensus issue raised yesterday. This will require rolling back our Ropsten network state to before the invalid block, leading to a very large network reorg. As such users should expect instability in the Ropsten network and continue to avoid using it for ongoing testing not directly related to testing consensus-level issues and reorgs.
Posted Jul 22, 2021 - 17:28 UTC
Identified
We are aware of potential consensus issues on the Ropsten testnet related to the upcoming London hard fork. After these issues are corrected in all likelihood the Ropsten network will be rolled back to block 10679536 or earlier. As such, we recommend avoiding using the Ropsten network for ongoing testing until these consensus issues are resolved and new clients released and deployed by miners and infrastructure providers.

Further details of the consensus issue are available at: https://notes.ethereum.org/@timbeiko/ropsten-postmortem
Posted Jul 21, 2021 - 19:23 UTC
This incident affected: Peer-to-peer Networks (Ethereum Ropsten Peer-to-peer Network) and Infura Ethereum API (Ropsten HTTPS JSON-RPC API, Ropsten WebSocket JSON-RPC API, Ropsten Logs, Ropsten Filters, Ropsten Archive Data).