Witti network outage
Incident Report for Infura
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 18:16 UTC
Identified
We have identified an issue in our Witti network service and are working on a fix.
Posted Jun 25, 2020 - 17:30 UTC
This incident affected: Witti (Beacon Chain API (beta)).