Degraded Performance on Celo mainnet

Incident Report for Infura

Resolved

This incident has been resolved.
Posted Aug 04, 2023 - 11:15 UTC

Update

We’re continuing to monitor the results, a block range limit of 100 has been enforced on eth_getLogs until the performance stabilizes.
Posted Aug 02, 2023 - 08:36 UTC

Update

We're continuing to monitor the results.
Posted Aug 01, 2023 - 07:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2023 - 18:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 27, 2023 - 07:20 UTC

Update

Our team remains fully engaged in resolving the performance issues on the Celo mainnet. Your patience is greatly appreciated
Posted Jul 27, 2023 - 00:36 UTC

Investigating

We are evaluating the mitigation based on user reports and will provide a further update ASAP
Posted Jul 26, 2023 - 13:51 UTC
This incident affected: Infura Celo APIs (Celo Mainnet HTTPS JSON-RPC API).