Degraded performance for Polygon Mainnet API
Incident Report for Infura
Resolved
This incident has been resolved. At this time we have limited eth_getLogs requests to a block range of 3500 for the Polygon Mainnet API.
Posted Jan 14, 2022 - 23:13 UTC
Update
In order to maintain service stability, we have had to implement a limit on the block range for eth_getLogs methods to the Polygon Mainnet API. We are currently tuning this value to ensure that we can provide the best experience and will update once we have a final limit value.
Posted Jan 14, 2022 - 20:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2022 - 20:16 UTC
Investigating
We have observed degraded performance on some Polygon Mainnet API services, manifesting as elevated response times for a portion of users accessing the listed components. We are currently investigating to pinpoint a root cause and remediate.
Posted Jan 14, 2022 - 14:11 UTC
This incident affected: Infura Ethereum Layer 2 APIs (beta) (Polygon Mainnet (beta)).