429 Rate Limiting Errors Across Multiple Networks

Incident Report for Infura

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 15:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2026 - 20:34 UTC

Investigating

We are currently observing sporadic 429 (Too Many Requests) responses affecting multiple networks including Monad Mainnet, Sei Mainnet, and Starknet Mainnet. Our team is actively working to identify and resolve the issue. We appreciate your patience and will provide updates as they become available.
Posted Jan 16, 2026 - 05:05 UTC
This incident affected: Infura Starknet APIs (StarkNet Mainnet HTTPS JSON-RPC API), Infura Sei APIs (Beta) (Sei Mainnet HTTPS JSON-RPC API), and Infura Monad APIs (Beta) (Monad Mainnet HTTPS JSON-RPC API).