Ongoing issues with Ropsten filters and subscriptions
Incident Report for Infura
Resolved
Reindexing of Ropsten logs is now complete, we are monitoring the network for any additional issues. Note that additional reorgs on Ropsten are likely if the competing chains are both being actively mined.
Posted Dec 25, 2021 - 20:45 UTC
Update
Indexing is continuing and is now ninety percent complete, we expect Ropsten logs to be caught up with the new chain in the next ten minutes or so.
Posted Dec 25, 2021 - 20:39 UTC
Update
Reindexing is continuing but proceeding at a slower rate than expected, we expect recent Ropsten logs to be available in thirty or forty-five minutes.
Posted Dec 25, 2021 - 20:11 UTC
Update
Reindexing of Ropsten logs is proceeding as expected, we expect all historical logs be to reindexed in the next ten to fifteen minutes.
Posted Dec 25, 2021 - 19:56 UTC
Update
The size of the reorg is requiring us to reindex historical blocks for logs and events, thus that system will lag behind while the datastore is rolled back. We expect the service to stabilize here shortly.
Posted Dec 25, 2021 - 19:45 UTC
Identified
We have confirmed the root cause as a large reorganization on Ropsten. The network is finalizing onto a new chain and it sheer size of the reorg is causing some of our indexing systems to lag behind but things are starting to recover.
Posted Dec 25, 2021 - 19:37 UTC
Update
This issue seems to be caused by two competing Proof of Work chains on Ropsten, we are continuing to investigate.
Posted Dec 25, 2021 - 19:32 UTC
Investigating
We are investigating an ongoing issue w/ Ropsten filters and subscriptions.
Posted Dec 25, 2021 - 19:24 UTC
This incident affected: Infura Ethereum API (Ropsten HTTPS JSON-RPC API, Ropsten WebSocket JSON-RPC API, Ropsten Logs, Ropsten Filters).