Performance degradation for filters request on websockets endpoint
Incident Report for Infura
Resolved
We have resolved this issue and have re-enabled 'eth_getFilterLogs' requests. Sorry for the inconvenience.
Posted Jul 15, 2020 - 20:11 UTC
Investigating
We are experiencing performance degradation for certain filter requests (specifically eth_getFilterLogs) on our websocket endpoint. Note that this performance degradation is limited only to filter requests and has no effect on subscriptions. Users requesting 'eth_getFilterLogs' may be seeing an increase in error responses and/or possible disconnects. We ask that users use 'eth_getLogs' instead of 'eth_getFilterLogs' to avoid this issue.
Posted Jul 06, 2020 - 22:23 UTC
This incident affected: Infura Ethereum API (Mainnet WebSocket JSON-RPC API).